After KDE 6.1 update games are flickering

Hello 3 days i did system update as a daily function
After that KDE upgraded to 6.1 and on X11 i have issues with steam games flickering, (cannot play on wayland because keyboard shortcuts are still not fixed so cannot even launch obs studio recording)
desktop is visible when game flickers and starting to be unresponsive
So i have hold out the upgrade till today, for now i will restore the previous snapshot but how long can i keep like that. Any resolution possible known?

System:
  Kernel: 6.9.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=bd6ec518-0675-438b-8673-51b1fb05d518 rw rootflags=subvol=@
    quiet loglevel=3 amdgpu.ppfeaturemask=0xffffffff ibt=off
  Desktop: KDE Plasma v: 6.1.0 tk: Qt v: N/A info: frameworks v: 6.3.0
    wm: kwin_x11 with: krunner vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: B450 AORUS ELITE
    serial: <superuser required> uuid: <superuser required> UEFI: American
    Megatrends LLC. v: F65a date: 02/09/2023
CPU:
  Info: model: AMD Ryzen 7 5700G with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
    process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000D
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 2625 high: 3792 min/max: 400/4673 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 3092 2: 400 3: 3033
    4: 3033 5: 400 6: 3033 7: 3035 8: 3041 9: 3039 10: 3792 11: 3034 12: 3034
    13: 3575 14: 3033 15: 400 16: 3034 bogomips: 121375
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT]
    vendor: Sapphire driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: HDMI-A-1 empty: DP-1, DP-2, DP-3, Writeback-1
    bus-ID: 03:00.0 chip-ID: 1002:73df class-ID: 0300
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
    s-diag: 777mm (30.58")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Samsung LC27G5xT
    serial: <filter> built: 2021 res: 2560x1440 hz: 60 dpi: 109 gamma: 1.2
    size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.1.2-arch1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6700 XT (radeonsi
    navi22 LLVM 17.0.6 DRM 3.57 6.9.6-zen1-1-zen) device-ID: 1002:73df
    memory: 11.72 GiB unified: no
  API: Vulkan v: 1.3.279 layers: 14 device: 0 type: discrete-gpu name: AMD
    Radeon RX 6700 XT (RADV NAVI22) driver: mesa radv v: 24.1.2-arch1.1
    device-ID: 1002:73df surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.1.2-arch1.1 (LLVM
    17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-2: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 0a:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-3: AMD Family 17h/19h HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 0a:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  API: ALSA v: k6.9.6-zen1-1-zen status: kernel-api with: aoss
    type: oss-emulator tools: N/A
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 06:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager,systemd-timesyncd
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9:4
    chip-ID: 0a12:0001 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: N/A
Drives:
  Local Storage: total: 1.56 TiB used: 344.76 GiB (21.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7 temp: 29.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: GOODRAM model: SSDPR-CL100-480-G2
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: V4.9 scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 vendor: PNY model: CS900 240GB SSD
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 0615 scheme: GPT
Partition:
  ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 26.58 GiB (26.6%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 1 GiB size: 1023 MiB (99.80%)
    used: 584 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 830.51 GiB size: 830.51 GiB (100.00%)
    used: 318.18 GiB (38.3%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%)
    used: 26.58 GiB (26.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%)
    used: 26.58 GiB (26.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 31.21 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 36.4 C mobo: N/A gpu: amdgpu temp: 31.0 C
    mem: 30.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 894
Info:
  Memory: total: 32 GiB available: 31.21 GiB used: 4.67 GiB (15.0%)
  Processes: 433 Power: uptime: 4m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 12.47 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 256 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 1848 libs: 565 tools: paru Compilers:
    clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1
    running-in: konsole inxi: 3.3.35
Garuda (2.6.26-1):
  System install date:     2024-05-06
  Last full system update: 2024-06-24
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            
2 Likes

version 6.1.1 of plasma fixed the issue

issue is not resolved, i thought so because it wasn’t flickering on first tests

still i need to revert to 6.0 for stable gaming

downgrade and keep it there while the bug is not fixed.

well i think i would need to downgrade whole lot of dependencies for plasma??

plasma-activities-6.1.1-1  plasma-activities-stats-6.1.1-1  plasma-browser-integration-6.1.1-1
plasma-desktop-6.1.1-1  plasma-firewall-6.1.1-1  plasma-integration-6.1.1-1  plasma-nm-6.1.1-1
plasma-pa-6.1.1-1  plasma-systemmonitor-6.1.1-1  plasma-thunderbolt-6.1.1-1
plasma-workspace-6.1.1-1  plasma5-themes-sweet-full-git-r374.9298c7f-1  plasma5support-6.1.1-1
plasma6-applets-window-title-0.5-1.1  plasma6-wallpapers-blurredwallpaper-3.0.1-1.1

disable compositor

1 Like

I was also noticing this issue when using kwin_x11, and disabling the compositor only helped a little bit (either using the toggle key shift+ alt+ F12 or integrating it into gamemode) .

For some reason it seemed like it would only flicker if I had other windows open that had window decorations (windows would constantly lose and regain the decorations in an endless loop), and might be related to numerous recent kwin_x11 bugs I’m seeing on the KDE bugtracker (this is most likely to do with things crashing and restarting). Also, I’ve noticed it only happens in certain games, specifically graphical intensive games I usually run fullscreen modes.

I don’t know. Downgrading has saved me from headaches with KDE.

Don’t imagine KDE 6.xx with wayland to stable for several months.

On my systems I am dealing with minor issues, like Plasma shell doing restarts on itself 1x - 2x per day. You either go with KDE and endure the bugs or switch DE.

I am sticking with KDE because It works but it is buggy :smiley: I expect this to change in about 12 months. Wayland + new KDE bugs being ironed out.

well i have minimized obs studio window, and nothing was up on the desktop, every apps were minimized, but it still was flickering

i’m always running fullscreen mode only

haven’t tried yet shift alt f12

i like KDE because for gaming i think it’s best
and i’m still playing on x11 session instead of wayland, because shortucts aren’t working with wayland still

1 Like

as soon as i open obs studio, and even minimize it, flickering starts, it looks like obs studio being restarted

if i hit alt shit f12 in desktop, it restarts obs studio and disabling compositor is being turned off

LoL. Maybe it works on wayland? You’re on amdgpu, right?

I am thinking - You can’t rely on x11 indefinitely(Maybe couple years is ok but…) Maybe you can push your setup to wayland. amd support is ok in general.

I would test it, but it seems I would need to create an active stream… Don’t know if this is worth it. :grin:

i would love to use wayland, but on wayland session keyboard shortcuts aren’t working, i cannot start recording on wayland through keyboard shortcuts because they still do not work properly that’s why i’m using x11

No work a round for wayland? Can’t be :smiley:

1 Like

you can try if shortcuts works for you, because for me they aren’t

Recording works via keyboard. I need to do a lot of work before I could test Streaming since it needs to be connected to the streaming client it seems.

Try other KB shorcuts. Like: CTRL + Numpad4 etc simple and different so it isn’t mixed up.

Getting my streaming rights for youtube in 24h.

1 Like

i’m not streaming, i’m using recording. Ok let me test it once more if that works, have you been testing recording while you were in game? because shortcuts works if you focus on obs window, but if you are in game they aren’t

1 Like

Ok. It seems Hotkeys for other apps do not work. Maybe you can ALT + TAB to OBS and start it like that?

Another idea would be to use KDE settings manager to set OBS keys there! However , the default option for apps is blank and I am not sure how this works or whether it would be different at all. Hmm… You could run a script that runs OBS recording. For example, whith Dark and Darker running , my terminal shortcut works. I need to double press it and it runs terminal over the game. So running OBS recording with a script might do it!

1 Like

hmm obs recording with a script, i’m not that familliar with obs, can you guide me a little?

  1. First you are going to create a bash script.
cd  Documents/    
mkdir CustomScript
cd CustomScript 
touch obs.sh

Use your text editor to open it.
Paste this inside the file obs.sh:

#!/bin/bash


obs --startrecording

In the same directory make the script executable:

sudo chmod +x obs.sh

Now go to System Settings (KDE settings).
2. Keyboard → Shortcuts.
3. Add new (top/middle of the window) → Command or Script.
4. Choose… → Open Documnets/CustomScript/obs.sh

Now you have made the command keyboard shorcut for obs script —> Add custom shortcut —> Insert your keyboard shortcut — CTRL + Numpad3 etc.

This should work.

1 Like

A you are using cli from obs for that i thought you want me to create some script in lua :stuck_out_tongue:

Ok i will try that approach

but in documentation i haven’t found anything like --stoprecording

also obs --startrecording starts a new instance of obs studio
same with obs --stoprecording it want’s to start a new instance of obs studio app

1 Like