Adding internal storage drive to updatedb.conf

How do I include new internal storage drive in the updatedb.conf file which reads as--

# Modified by Garuda Linux to exclude snapshots

PRUNEPATHS = "/afs /media /mnt /net /sfs /tmp /udev /var/cache /var/lib/pacman/local /var/lock /var/run /var/spool /var/tmp /.snapshots"

What can I safely alter? My new drive is located at /run/media/arthur/first

garuda-inxi
sudo garuda-inxi
System:
  Kernel: 5.17.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=15449417-b8af-455f-ac34-892500896455 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: GNOME v: 42.1 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 42.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Hewlett-Packard product: HP Compaq Elite 8300 SFF
    v: N/A serial: <filter> Chassis: type: 4 serial: <filter>
  Mobo: Hewlett-Packard model: 3397 serial: <filter> UEFI: Hewlett-Packard
    v: K01 v03.06 date: 02/12/2018
CPU:
  Info: model: Intel Core i5-3470 socket: BGA1155 bits: 64 type: MCP
    arch: Ivy Bridge family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 1597 min/max: 1600/3600 base/boost: 3200/3800 scaling:
    driver: intel_cpufreq governor: powersave volts: 1.0 V ext-clock: 100 MHz
    cores: 1: 1597 2: 1597 3: 1597 4: 1597 bogomips: 25542
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GK208B [GeForce GT 730] vendor: ASUSTeK driver: nvidia
    v: 470.129.06 alternate: nouveau,nvidia_drm non-free: 470.xx+
    status: legacy-active (EOL ~2023/24) arch: Kepler pcie: gen: 1
    speed: 2.5 GT/s lanes: 4 link-max: gen: 2 speed: 5 GT/s lanes: 8
    bus-ID: 01:00.0 chip-ID: 10de:1287 class-ID: 0300
  Display: server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: nvidia
    unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: nvidia
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 271x203mm (10.67x7.99")
    s-diag: 339mm (13.33")
  Monitor-1: HDMI-0 res: 1024x768 hz: 60 dpi: 63
    size: 410x230mm (16.14x9.06") diag: 470mm (18.51") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GT 730/PCIe/SSE2
    v: 4.6.0 NVIDIA 470.129.06 direct render: Yes
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1e20 class-ID: 0403
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 4
    link-max: lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:0e0f class-ID: 0403
  Sound Server-1: ALSA v: k5.17.9-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard
    driver: e1000e v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1502
    class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 1-1.1:3 chip-ID: 0a12:0001 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 4.08 TiB used: 119.04 GiB (2.9%)
  ID-1: /dev/sda maj-min: 8:0 vendor: A-Data model: SU635 size: 447.13 GiB
    block-size: physical: 512 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4c18 temp: 32 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 18d 14h cycles: 390
    read: 454 KiB written: 270 KiB
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST4000LM016-1N2170
    family: Laptop HDD size: 3.64 TiB block-size: physical: 4096 B
    logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD rpm: 5400
    serial: <filter> rev: 0003 temp: 29 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 1y 44d 4h cycles: 2111
    read: 1.12 TiB written: 11 TiB Pre-Fail: attribute: Spin_Retry_Count
    value: 100 worst: 100 threshold: 97
Partition:
  ID-1: / raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
    used: 68.22 GiB (15.3%) fs: btrfs block-size: 4096 B dev: /dev/sda2
    maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
    used: 68.22 GiB (15.3%) fs: btrfs block-size: 4096 B dev: /dev/sda2
    maj-min: 8:2
  ID-4: /var/log raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
    used: 68.22 GiB (15.3%) fs: btrfs block-size: 4096 B dev: /dev/sda2
    maj-min: 8:2
  ID-5: /var/tmp raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
    used: 68.22 GiB (15.3%) fs: btrfs block-size: 4096 B dev: /dev/sda2
    maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.3 GiB used: 283 MiB (0.9%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 39 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 275 Uptime: 2h 14m wakeups: 0 Memory: 31.3 GiB
  used: 3.59 GiB (11.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: 1650 pacman: 1636 lib: 372 flatpak: 14
  Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: kitty
  inxi: 3.3.16
e[1;34mGaruda (2.6.3-2):e[0m
e[1;34m  System install date:e[0m     2022-05-03
e[1;34m  Last full system update:e[0m 2022-05-22
e[1;34m  Is partially upgraded:  e[0m No
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m No/Undetected
e[1;34m  Snapshots:              e[0m Snapper (maybe)
e[1;34m  Failed units:           e[0m 

Seems media is by default included, IDK if it include /arthur/first.

Just change it to

PRUNEPATHS = "/afs /media /run/media/arthur/first /mnt /net /sfs /tmp /udev /var/cache /var/lib/pacman/local /var/lock /var/run /var/spool /var/tmp /.snapshots"

Or wait for more answers.

Thanks boss. I sorta messed up locate editing the conf file and reinstalled mlocate to get locate working again. fun stuff but Imma wait and see what else turns up. :slight_smile:

Edited topic subject for added clarity/precision on issue.

Solved. I mounted the drive to my home dir.
sudo mount /dev/sdb1 /home/arthur/first

After sudo updatedb, locate works just fine.
First time is scary stuff.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.