Add/Remove Software error | pamac

I have been updating and installing some softwares from the "Add/Remove Software" but recently I'm getting an error like this : " Failed to prepare transaction: invalid or corrupted database " I thought any particular file is courrupted but this happen with all the other and everytime. How can I fix this ?

Try from a terminal the following commands:

sudo rm -R /var/lib/pacman/sync
sudo pacman -Syuf

When I typed the first command, I got : "rm: cannot remove '/var/lib/pacman/sync': No such file or directory"
when I typed the second one, it said: error: invalid option '-f '

:confused:

:pensive:
Sorry, maybe try this (cleans the cache and updates):
sudo pacman -Scc
sudo pacman -Syu
I'm not sure it will solve the problem, but won't hurt.

when I typed this, it said : sudo pacman Syu
error: no operation specified (use -h for help)

Its sudo pacman -Syu. I think it was a typo.

4 Likes

Sorry,
sudo pacman -Syu
Typing from my mobile...
You see: I wasted time looking for the text formatting chars and didn't read what I was typing :cry:
But now I edited my typo :slight_smile:

3 Likes

Find out the package name of the application you want to install and have a try in the console.

sudo pacman -Syu *package*

I'm hoping that we can get more output to see whats going on

3 Likes

I want to install Wireshark, what command should I type ?

Lets search for packages containing wireshark:

λ pacman -Ss wireshark
community/termshark 2.2.0-1
Terminal UI for tshark, inspired by Wireshark
community/wireshark-cli 3.4.6-1
Network traffic and protocol analyzer/sniffer - CLI tools and data files
community/wireshark-qt 3.4.6-1
Network traffic and protocol analyzer/sniffer - Qt GUI

So to install, just type (assuming you want the GUI)

sudo pacman -Syu wireshark-qt
1 Like

thanks,, this worked

Alright, nice. Since it worked this time I guess its safe to assume that the error was just caused by a corrupted download. :+1:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.