Add and remove missing after latest update

Hi everyone i tried to update with sudo pacman -Syu ``
Then restarted and clicked on add remove and it will not open ,i went to application launcher and click add remove and theres nothing there

         [email protected];          .db:              [email protected];
       ,tSXX°          [email protected];  Packages: 1784 (pacman)
     .SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;  Shell: fish
   ,888S                                     pd!  Resolution: 1920x1080
  8X88/                                       q   Terminal: Navigator
   x%88        [email protected]@[email protected]@[email protected]@[email protected]@[email protected]@X.        CPU: AMD Ryzen 7 4800H with Radeon Graphics (16) @ 2.9GHz
     dxXd    dB8b8b8B8B08bB88b998888b88x.         Memory: 4301MiB / 15484MiB (27%)
      dxx8o                      [email protected]@;.
        dx88                   [email protected]
          d:[email protected]

╭─rob at rob-tufgamingfa506iifx506ii in ⌁
╰─λ neofetch
                                                   [email protected]
                     .%;888:8898898:               -------------------------------
                   x;XxXB%89b8:b8%b88:             OS: Garuda x86_64
                .8Xxd                8X:.          Host: TUF Gaming FA506II_FX506II 1.0
              .8Xx;                    8x:.        Kernel: 5.12.7-160-tkg-bmq
            .tt8x          .d            x88;      Uptime: 1 hour, 16 mins
         [email protected];          .db:              [email protected];    Packages: 1784 (pacman)
       ,tSXX°          [email protected];   Shell: /usr/bin/fish 3.2.2
     .SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;   Resolution: 1920x1080
   ,888S                                     pd!   DE: Plasma 5.21.5
  8X88/                                       q    WM: KWin
  GBB.                                             Terminal: alacritty
   x%88        [email protected]@[email protected]@[email protected]@[email protected]@[email protected]@X.         Terminal Font: FantasqueSansMono
     dxXd    dB8b8b8B8B08bB88b998888b88x.          CPU: AMD Ryzen 7 4800H with Radeon G
      dxx8o                      [email protected]@;.             GPU: AMD ATI 05:00.0 Renoir
        dx88                   [email protected]               GPU: NVIDIA GeForce GTX 1650 Ti Mobi
          d:[email protected]                 Memory: 5727MiB / 15484MiB

╭─rob at rob-tufgamingfa506iifx506ii in ⌁

```╰─λ sudo reflector --country Australia --latest 15 --age 2 --fastest 20 --protocol https --sort rate --save /etc/pacman.d/mirrorlist
lated to Garuda Linux and its assistance ```

Hi there, see this thread.

And search forums before posting.


Thank you sorry i forgot to mention i did read that ,but ill read again.Thanks for your help seems every update gets more difficult .thanks for your time .

Thanks for notifying @SGS . I'm currently messed up as this forum after PacMan update.
The below is for Pamac.

sudo pacman -R pamac-flatpak-plugin
sudo pacman -S flatpak
sudo pacman -S pamac-flatpak-plugin

I'm happy if it works
The below is for PacMan :

Step by Step support by Peer Review :relieved::
Due to update to PacMan 6 ,the GUI Installer - Add/Remove Software is not working. Personally for me Pacman terminal too failed after update.
I tried and partially got my terminal working


I clone Pacman and builded it

Source : Support for users who updated to PacMan 6

We need to merge two Pacman config files.
Follow below steps

diff /etc/pacman.conf /etc/pacman.conf.pacnew

2.Copy output to clipboard

sudo rm /etc/pacman.conf
sudo mv ./pacman.conf.pacnew ./pacman.conf

4.Keep Cache directory commented (add # before line start)

5.Add the below at the end of new pacman.conf file


On middle add

#SigLevel = Never
Include = /etc/pacman.d/chaotic-mirrorlist

  1. Uncomment the following (remove # at start; f line)

#Include = /etc/pacman.d/mirrorlist

#ParallelDownloads = 5

  1. Atlast enter to resume ur daily Work :grinning_face_with_smiling_eyes:

sudo pacman -Syyu
Check by Refreshing Keyrings in Garuda Assisant (Blue Eagle icon)

If you need another installer like paru (Pacman wrapper based on yay) , type following command one by one

sudo pacman -S --needed base-devel
git clone
cd paru
makepkg -si



And, will pamac work after your guide?


It didnt help pacmac for me. Merged those files and edited.

Can someone upload the correct pacman.conf please.

There is pacman and pamac.
pacman work fine.
pamac need a fix.
You must wait or use other GUI.

To add to SGS' post,

pamac fix ----> this is a MANJARO project, so you have to wait for them.
While waiting, you can use terminal commands in the meantime


building Octopi from source worked for me... I mostly just use it for the update notifications and just update via pacman and paru though. Wonder if there is a notifier that hooks directly into pacman then I wouldn't need a gui one.

1 Like
octopi may be found in the following packages:
  chaotic-aur/octopi 0.11.0-1    	/usr/bin/octopi
  chaotic-aur/octopi-dev 0.12.0-2	/usr/bin/octopi

Why from source? :slight_smile:

1 Like

Because i mangled my pacman.conf like a moron xD I fixed it but took me forever. Why is it always the simplest things that get you? (somehow multilib and multilib testing got enabled at the same time)

Jonathon Falconer Fantastic love your work my system is flying again

Cheers H.V. :rofl: lol

Problem solved. Solution : New Update releasedNew Update Released

1 Like