Activation of Network Connection Failed

Hey,

So I just installed Garuda Linux and was thinking about how to make it more secure. Read some articles about UFW and GUFW. So went and installed GUFW through the Add/Remove Software tool in Garuda.

After installing GUFW, I enabled it and then restarted my computer to check if it remains enabled after reboot.

Now, after reboot, the system can't connect to the internet and pops up the message - "Activation of Network Connection Failed"

I tried restoring using TimeStap but same issue...

Finally i shut down my system opened Windows (mine is a dual boot system) and after a while logged back into Garuda. Now the internet works.

The thing is.. If I restart my PC network connection doesn't work! But if I shut down and then start it, the internet is working fine!

Why is this? What is causing this issue?

Thanks,

p.s: Can you share some ways to make the system more secure. Checked Arch Wiki already.. most of the things they said were quite intuitive - things like passwords and stuff. I was wondering how to keep the PC safe from viruses, malware, keyloggers, and stuff.

Well, the same principles apply. Don't visit dodgy sites, don't install software from places you don't trust, don't run software as admin, etc.
Except under Windows (maybe you should remove that?), I've never seen these things.

2 Likes

Win know only win (M$), sometimes win block network connection on shutdown.

reboot, network is off

Timeshift.


If you search in forum, you will find that Garuda doesn't support dual boot with win.
Some problem is shown in this topic.


UFW/GUFW is not guilty, If UFW block something then everytime :slight_smile: no matter how you start the PC.

4 Likes

Got it.. thanks :slight_smile:

plan on removing Windows soon!

What do you suggest? Should I just format the drive Windows is on????

Windows is running on my SSD whereas Garuda is on my HDD! Could that still cause issues???

Thank you..

How would you suggest removing Windows?? Just formating the drive it is on??

Windows is actually on a separate Drive (not partition)..

Windows is running on my SSD whereas Garuda is on my HDD

Did you take the chance to have a look on the internet?
There are many suggestions, most likely useless in my opinon...
But you could give them a try, e.g.:

yeah went through all most of them ranking on the search engine.. wasn't helpful at all!

In fact i have actually gone through this exact article.. wasn't much help..

1 Like

If you can / want to do without Windows, install Garuda on the SSD. That is what gives Garuda the right drive!

2 Likes

You should try to correct this problem before uninstalling Windows or the problem may persist. Windows is likely causing this.

Go into the advanced properties for your network adapter in the Windows device manager. Disable any settings to do with your network adapter that involve power saving.

The problem usually is that Windows disables the adapter at the bios/firmware level to save power. This persists when you start up Linux and the adapter cannot be initiated.

Windows as usual, is likely at fault here.

Assuming you are using WiFi (you never even stated wifi or Ethernet), there is one other possibility. Possibly MAC randomization is at fault. Search for the terms "disable MAC Address randomization. Disable it then reboot your computer and router.

We have our privacy guide on wiki. Privacy usually comes hand-to-hand with security. Can also recommend Mental Outlaw as a privacy/security red pill.

1 Like

Please post your system specifications and tell us if you are using Ethernet or Wifi if you have both on your system.

Please post:

inxi -Fxxxza 

Post outputs only as text, no pics or videos on technical help requests please.

I am using Ethernet..

well, my ethernet cable is connected to a router and then another ethernet cable is connecting my PC with the router..

I am running Garuda on a desktop and not on Laptop.

As such, MAC address randomization shouldn't be an issue in my instance, should it?

Nope, not with Ethernet (generally).

I'm going to guess you have an intel ethernet adapter.

If that is the case, test the LTS kernel.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.