ACPI errors in journalctl, xdg-desktop-portal-kde

Hi!

This is my first post on this forum and with this occasion I also want to say that I love this Garuda project! I've recently moved from Windows and so far I have had no problem in using Garuda, everything you guys made is very easy and intuitive to use - also, the forum layout, and overall aesthetic is so nice! I hope this project runs indefinitely and keeps on getting better, and good luck to the devs (i hope they are called devs xd)

TLDR: I have some errors in journalctl, dont know why they are there, and came here to ask you if they are harmless, meanwhile maybe learning something new from you

I have been running this OS for the past 2 or 3 weeks and so far I haven't had any issues apart from 2 crashes (or rather one crash and one freeze). One happened 7-6 days or so ago, and the other the next day. The crash was a complete black screen, while I was playing League of Legends on lutris. I was already in my 3rd match, when at the 8th minute or so, just black screen. PC fan and leds restart, but pc didn't automatically boot again. I just long press the power button, (it shuts completely down) then press power button again and everything worked normally until next day. I was minding my day, after 2 hours or so when I was on chromium, opened YouTube tab, and then screen froze. Pressing caps didn't light up the caps button on keyboard, quick press power button didn't shut down the pc, sadly I have read only recently that i should've tried ssh'd into the host but I didn't know at the time.

In the meantime, I have changed the C state in bios as read here

Since then I haven't had the issue again, but I've started being interested in reading on how to fix it, I've learned how to read the journalctl log thing, I've tried going back in time to when the crash happened but couldn't seem to find anything out of the ordinary.

This is the garuda-inxi command

╭─[email protected] in ~
╰─λ garuda-inxi
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "",
LC_ALL = (unset),
LC_ADDRESS = "ro_RO.UTF-8",
LC_NAME = "ro_RO.UTF-8",
LC_MONETARY = "ro_RO.UTF-8",
LC_PAPER = "ro_RO.UTF-8",
LC_IDENTIFICATION = "ro_RO.UTF-8",
LC_TELEPHONE = "ro_RO.UTF-8",
LC_MEASUREMENT = "ro_RO.UTF-8",
LC_TIME = "en_GB.UTF-8",
LC_NUMERIC = "ro_RO.UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
System:
Kernel: 5.19.11-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=69cb4a22-33d6-4af4-8a49-29a7895df4d2 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 2301
date: 04/19/2019
CPU:
Info: model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen level: v3
built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1 stepping: 1
microcode: 0x8001137
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3309 high: 3393 min/max: 1550/3200 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3200 2: 3392
3: 3200 4: 3200 5: 3200 6: 3380 7: 3392 8: 3375 9: 3393 10: 3392 11: 3392
12: 3200 bogomips: 76652
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT vulnerable
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: XFX Pine driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands
process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: DP-2,DP-3 empty: DP-1,DVI-D-1,HDMI-A-1 bus-ID: 09:00.0
chip-ID: 1002:67df class-ID: 0300
Device-2: MacroSilicon USB Video type: USB
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 3-2:2
chip-ID: 534d:2109 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1200 s-dpi: 96 s-size: 1016x317mm (40.00x12.48")
s-diag: 1064mm (41.9")
Monitor-1: DP-2 mapped: DisplayPort-1 pos: primary,left model: HP ZR2440w
serial: <filter> built: 2012 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
size: 518x324mm (20.39x12.76") diag: 611mm (24.1") ratio: 16:10 modes:
max: 1920x1200 min: 640x480
Monitor-2: DP-3 mapped: DisplayPort-2 pos: primary,right
model: Asus BE24A serial: <filter> built: 2016 res: 1920x1200 hz: 60
dpi: 94 gamma: 1.2 size: 518x324mm (20.39x12.76") diag: 611mm (24.1")
ratio: 16:10 modes: max: 1920x1200 min: 640x480
OpenGL: renderer: AMD Radeon RX 580 Series (polaris10 LLVM 14.0.6 DRM
3.47 5.19.11-zen1-1-zen) v: 4.6 Mesa 22.1.7 direct render: Yes
Audio:
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: XFX Pine driver: snd_hda_intel bus-ID: 3-2:2 v: kernel
chip-ID: 534d:2109 pcie: class-ID: 0300 gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 09:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0b:00.3
chip-ID: 1022:1457 class-ID: 0403
Device-3: MacroSilicon USB Video type: USB
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo
Sound Server-1: ALSA v: k5.19.11-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.58 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 04:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 82.65 GiB (17.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Plextor model: PX-512M9PeG
size: 476.94 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 1.07
temp: 44.9 C scheme: GPT
Partition:
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 82.65 GiB
(17.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 82.65
GiB (17.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 82.65
GiB (17.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 82.65
GiB (17.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.54 GiB used: 2.8 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 38.8 C mobo: N/A gpu: amdgpu temp: 54.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 883
Info:
Processes: 342 Uptime: 29m wakeups: 0 Memory: 15.55 GiB used: 4.01 GiB
(25.8%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1531 libs: 443
tools: octopi,paru,yay pm: flatpak pkgs: 0 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.21
Garuda (2.6.7-1):
System install date:     2022-09-18
Last full system update: 2022-09-27
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

What I did find though are these errors
In journalctl -b -p err journalctl (also pastebin because I exceeded body limit)

And also in dmesg (sorry if I put it in pastebin, but this output is so long)

I don't seem to run into any crashes or bugs lately, but maybe they were because of these?
So far I googled around, and for the ACPI error I have no problems that other people encounter related to the error (nothing that I know how to test at least)

For the xdg-desktop-portal-kde[2929]: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
I have looked into processes and it seems to be running without me restarting it, but I don't know why the error appears.

Also btrfs-assistant is running as well, and the bashrc initial setup seems to be successful (any way to check what bashrc setup it's talking about?)

The only bug I have is that KDE connect doesnt automatically connect to my phone, I have to restart the kdeconnectd then it does, but i dont this its related to any of these.

Is there any way to clean up these errors so maybe they don't appear in the future?
Or is this just common and should be ignored (kinda pressing on my ocd though)

I'm also hoping of maybe learning something new out of these things :smiley:
Thanks for the help! (and hope I didn't open just another useless topic)
(I also hope I formatted things nicely, I tried following the guides)

Hi there, welcome to the forum.
The xdg-desktop-portal crash should be this bug in the Arch reporting system (referencing also the upstream KDE bug, I think).

I noticed that as well in my system, but I must say it is not currently affecting the usability of any application, so I haven't investigated much.
As regards the ACPI errors, well..., you can keep on searching, maybe update the BIOS, searching in the jungle of kernel boot parameters, maybe using this guide (not limited to!), but I think that they are often due to non-standard BIOS implementations.
I think this article summerizes the point quite well:

6 Likes

Thank you for the swift reply!

Oh, I see, so regarding the ACPI errors, basically if i learn more about kernel, I could make my own custom config, and theoretically, by using the correct parameters for my components I wouldn't be getting those errors, right? That's cool

As for the xdg-desktop-portal bug I guess ill just ignore it aslong as it doesn't interfere with anything

Thank you!

1 Like

I agree with ignoring the xdg-desktop-portal errors for the moment.
For ACPI errors, it will certainly be instructive, but mine (very similar to yours), which I have always seen in all distributions (i.e. it was a fight begun loooong ago), have not disappeared by trying all the parameters in the guide above and many others suggested in internet searches.
After a while the fun ended, and since I have no obvious problems, I left it alone... :wink:
Good luck!

2 Likes

Tnx @filo I was looking for that bug for some time and I guess it wasn't open at first, I ended up uninstalling xdg-desktop-portal and xdg-desktop-portal-kde, but now that you pointed us on the Arch bug I will keep an eye!

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.