A different black screen issue

Hi,

Newbie here. I’ve read though several posts and FAQs around the ‘black screen’ issue. I’m working on a newly built desktop to install Garuda.

When I tried to refresh the mirrorlist, I received a lot of 5 second timeout warnings plus several 403 responses, so not sure if the list was fully updated but no new packages were found. I was able to start X from the text console, which stated it could be a problem with the Display Mansgers. I did look at X log and I do see this:

4.5501 (EE) Failed to load module "fbdev"
(module does not exist, 0)

4.550] (E) Failed to load module "vesa"
(module does not exist, 0)

4.5731 (E) AIGLX error: Calling driver entry point failed

Calling driver entry point failed
4.640] (EE) intel (0): Failed to submit rendering commands (Invalid argument), disabling acceleration.

Currently the Desktop is non-functional, so I’m typing the results from my phone. Any thoughts on how to continue to triage this do I can work from the desktop is greatly appreciated.

I’m just running the Intel 750 graphics that is integrated into the Asus motherboard.

Thanks for your help.

Did it work previously? If so, what changed (e.g. look at the output of paclog or in /var/log/pacman.log).

It would be worth making sure that it did get updated.

There's a snapshot function built-in for this exact situation. You can also use a live installer environment (also mentioned in the FAQ post) to get access to the installation (e.g. via a chroot).

3 Likes

This was a fresh install on this machine and it hasn't ever worked. I'll check the pacman.log to see if there is anything there.

I'll see if I can force the refresh. I run on 1 GB internet, so it shouldn't be a problem. Most were EMEA sites, so the latency there could be the problem. I'll try this afternoon after work.

If I don't find anything in the logs or can't get the mirrors to refresh, I'll try that. Is it possible the integrated graphics aren't robust enough to run the Dr460nized desktop? It says it supports OpenGL 4.5.

Thanks,

Richard

Please render the terminal output of inxi -Faz as requested in the template.

1 Like

Does the live installer image work? If so then the installed OS should work in exactly the same way, and it will provide a way for you to

.

1 Like

It does and I can log in to the desktop post install and go through the post-install steps but after that, I cannot launch anything from the app launcher, the background of the desktop disappears and there is, when I can click on an icon, renders out the icon next to it and there is a lot of 'jerky' rendering of different icons that is visible at the time and some panels doesn't even show but popups do sort of render where an icon is at, but not visible.

I will attempt to do it, since browsers don't even function post install, I can't copy it and post into the topic...it maybe a screen shot from the server from, say, my tablet or phone.

This means the base operating system is working and it is a later change you are making that breaks something.

You might want to be much more specific here. Which steps specifically are you performing?

Sounds like another pointer towards a networking issue that could well be causing this:

Without system information or log output it's going to be much more difficult to diagnose the issues.

2 Likes

Then, considering the above posts...

At this point perhaps it is time to go back to basics.

  • Format your USB key in, say FAT32
  • Download a new ISO. Download Garuda Linux from SourceForge.net
  • Check the ISO Download Garuda Linux from SourceForge.net
  • Download & install Ventoy to the USB key Ventoy
  • Copy/Paste the Garuda ISO into Ventoy -- follow the Ventoy webpage's instructions
  • Give it plenty of time to finish copying. It will take several minutes.
  • Reboot your computer into the newly created Garuda imaged USB key and proceed to do a normal installation to your hard drive. Nothing tricky. :wink:
  • After installation and rebooting, follow the post-install scripts, and reboot.
  • Report back.

EDIT: Back in a few. Installing dr460nized to this machine.
:smiley:

4 Likes

Okay...following some of Jonathon's suggestions to look at different logs, specifically:

I found the following in the log:

[2022-02-06T18:21:32-0600] [ALPM-SCRIPTLET] >>> This driver now uses DRI3 as the default Direct Rendering
[2022-02-06T18:21:32-0600] [ALPM-SCRIPTLET]     Infrastructure. You can try falling back to DRI2 if you run
[2022-02-06T18:21:32-0600] [ALPM-SCRIPTLET]     into trouble. To do so, save a file with the following
[2022-02-06T18:21:32-0600] [ALPM-SCRIPTLET]     content as /etc/X11/xorg.conf.d/20-intel.conf :
[2022-02-06T18:21:32-0600] [ALPM-SCRIPTLET]       Section "Device"
[2022-02-06T18:21:32-0600] [ALPM-SCRIPTLET]         Identifier  "Intel Graphics"
[2022-02-06T18:21:32-0600] [ALPM-SCRIPTLET]         Driver      "intel"
[2022-02-06T18:21:32-0600] [ALPM-SCRIPTLET]         Option      "DRI" "2"             # DRI3 is now default
[2022-02-06T18:21:32-0600] [ALPM-SCRIPTLET]         #Option      "AccelMethod"  "sna" # default
[2022-02-06T18:21:32-0600] [ALPM-SCRIPTLET]         #Option      "AccelMethod"  "uxa" # fallback
[2022-02-06T18:21:32-0600] [ALPM-SCRIPTLET]       EndSection

So I created the file and going to DRI2 and now the desktop is functional. I still get the occasional screen flicker, so I may have to invest in a dedicated video card versus using the integrated (or if flickering is a known issue, if you can point me to the right direction, that would be great).

Also, based on the FAQ for this issue, the reflector syntax didn't work for me, or at least for what you were wanting users to do, I found the following worked for me:

sudo reflector --latest 20 --sort rate --protocol https --save /etc/pacman.d/mirrorlist

Once i did this, it did pickup some additional libraries that needed to be upgraded (I did this prior to adding the file for X)

To close the loop, here is my system info. If you see anything that I you would recommend me to tune, please let me know, this is my first adventure into Arch (I come from an RHEL background). Much appreciated the support on this.

System:
Kernel: 5.16.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c031854c-7a15-4767-a315-d1138c857a8f rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: TUF GAMING B560M-PLUS WIFI v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 0820
date: 04/27/2021
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: Discharging
CPU:
Info: model: 11th Gen Intel Core i5-11600K bits: 64 type: MT MCP
arch: Rocket Lake family: 6 model-id: 0xA7 (167) stepping: 1
microcode: 0x40
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 800 high: 801 min/max: 800/4900 scaling:
driver: intel_pstate governor: powersave cores: 1: 801 2: 801 3: 800 4: 801
5: 801 6: 800 7: 801 8: 800 9: 801 10: 800 11: 800 12: 800
bogomips: 93888
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel RocketLake-S GT1 [UHD Graphics 750] vendor: ASUSTeK
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:4c8a class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: intel display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: HDMI1 res: 1920x1080 dpi: 70 size: 700x390mm (27.6x15.4")
diag: 801mm (31.5")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel Tiger Lake-H HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:43c8 class-ID: 0403
Sound Server-1: ALSA v: k5.16.5-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
port: 4000 bus-ID: 03:00.0 chip-ID: 10ec:8125 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:7 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 9.1 GiB (1.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B2QEXM7 temp: 31.9 C scheme: GPT
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 9.1 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 9.1 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 9.1 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 9.1 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.12 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 27.8 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 286 Uptime: 6m wakeups: 2 Memory: 31.12 GiB
used: 2.47 GiB (7.9%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1146 lib: 294 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12

BTW, we changed inxi -Faz to special garuda-inxi with some extra garuda infos.

  System install date:     2021-11-30
  Last full system update: 2022-02-06
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper

Please use three ~ in first and last line from terminal output :slight_smile:

I just changed it.

3 Likes

Thanks! Here is the update with using garuda-inxi:

System:
Kernel: 5.16.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c031854c-7a15-4767-a315-d1138c857a8f rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: TUF GAMING B560M-PLUS WIFI v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 0820
date: 04/27/2021
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: Discharging
CPU:
Info: model: 11th Gen Intel Core i5-11600K bits: 64 type: MT MCP
arch: Rocket Lake family: 6 model-id: 0xA7 (167) stepping: 1
microcode: 0x40
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 800 high: 801 min/max: 800/4900 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 801 3: 801 4: 800
5: 800 6: 800 7: 801 8: 801 9: 801 10: 801 11: 800 12: 800
bogomips: 93888
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel RocketLake-S GT1 [UHD Graphics 750] vendor: ASUSTeK
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:4c8a class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: intel display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: HDMI1 res: 1920x1080 dpi: 70 size: 700x390mm (27.6x15.4")
diag: 801mm (31.5")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel Tiger Lake-H HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:43c8 class-ID: 0403
Sound Server-1: ALSA v: k5.16.5-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
port: 4000 bus-ID: 03:00.0 chip-ID: 10ec:8125 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:7 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 9.89 GiB (1.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B2QEXM7 temp: 31.9 C scheme: GPT
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 9.89 GiB (1.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 9.89 GiB (1.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 9.89 GiB (1.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 9.89 GiB (1.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.12 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 27.8 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 303 Uptime: 29m wakeups: 6 Memory: 31.12 GiB
used: 2.68 GiB (8.6%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1157 lib: 296 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda (2.5.4-2):
System install date:     2022-02-06
Last full system update: 2022-02-07
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:
1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.