5.15.6-zen2-1-zen Virtualbox no longer working

Hello

I'm relatively new to both Linux itself and Arch Linux and ran a full update of my Garuda system as it was prompting that several packages needed updating. It also appears to have updated the kernel as well as it is now running on "Kernel: 5.15.6-zen2-1-zen"

This update appears to have done something to the drivers used by virtualbox. This was working without issue prior to this update but is now throwing the update
"kernel driver not installed (rc=1908)"

There are lots of articles about this and all advise to either just reboot, which doesn't solve this for me or purge and reinstall virtualbox. To do this I ran this:
Attempted to Purge virtualbox using Sudo pacman -Rn virtualbox
ran pacman -Qdt to find unlinked dependencies
Found virtualbox-host-modules-arch
Removed using sudo pacman -RN virtualbox-host-modules-arch
Ensured system sync by rnning sudo pacman -Syu nothing be done
ran sudo pacman -S virtualbox

once this was reinstalled I found an instruction for me to run the following command to get the kernel driver to install
sudo modprobe vboxdvr

but this throws this error
modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/5.15.6-zen2-1-zen

I've seen a very old article suggest that installing virtualbox-host-dkms will resolve this, but this in conflict with the the virtualbox-host-arch that I have installed

Other than this I have seen a suggestion to install the linux-headers package which I have also tried and there is still no driver to install from modprobe.

I've exhausted everything i can find through Google and don't know what else to try. Any suggestions?

Hi there, welcome.
Is virtualbox-meta installed?

3 Likes

Have you rebooted since updating? It is possible your installed kernel and running kernel no longer match so it can't use the modules.

2 Likes

@filo thank yo very much. Was hesitant because i said that package conflicted with virtalbox-host-arch but looking at the console something in those four lines is what it needed from virtualbox-meta

==> dkms install --no-depmod vboxhost/6.1.30_OSE -k 5.15.6-zen2-1-zen
==> dkms install --no-depmod vboxhost/6.1.30_OSE -k 5.15.6-arch2-1
==> depmod 5.15.6-zen2-1-zen
==> depmod 5.15.6-arch2-1

once this was installed modprobe vboxdrv ran and virtualbox is now fine.

2 Likes

This is normally and simply because the 5.15 kernel was installed but not the headers. If you install the headers and reinstall VB it will build the DKMS for the 5.15 and you're off to the races.

I'm a regular user of VirtualBox, and it is known as finicky with regards to the kernel it supports.

That is why I run Xanmod LTS kernel (which is stuck with 5.10.x), to minimize compatibility issues with it while considered still as a power-user kernel.

1 Like

We don't have those in Linux, those only exist on Windows. :grinning:

2 Likes

Deleted ;p

SNAP! - The Power (Official Video) - YouTube + user

What I meant of power-user for that context of highly-customized kernel for a specific use case.

2 Likes

We know, he's just bugging you ;p

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.