2 Keyboard shortcut issues

Only on one Garuda linux install do I have these odd issues.

  1. I need to switch between languages. I've tried various setting various key combinations, but regardless the action is the same. Basically when switching, regardless of which window I'm in, that window is no longer the active window. So I have to then click back into that window to be able to type. Really annoying...

  2. When switching between windows of the same application I like to use the Alt or Win + Apostrophe shortcut. This works UNLESS I have a file manager (Nautilus) window open. When switching between Applications (Alt or WIn + Tab) sometimes (not always) Nautilus will be in first place (on the left), so regardless of which app I'm in, if I want to switch to another Firefox window, Alt or Win + Apostrophe will take me to Nautilus. Only if I close Nautilus does App Window switching work as expected.

Kernel: 6.2.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=43f18a73-c753-4e08-9fba-b8afedfcb3ac rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=9431c5cc-6a40-4ec6-91b8-d397f24a4c4e loglevel=3 ibt=off
Desktop: GNOME v: 43.3 tk: GTK v: 3.24.36 wm: gnome-shell dm: GDM v: 43.0
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Sony product: VPCZ21TGX v: J004MUHH
serial: Chassis: type: 10 serial:
Mobo: Sony model: VAIO serial: BIOS: INSYDE
v: R0170H5 date: 06/16/2011
ID-1: BAT1 charge: 0 Wh condition: N/A volts: N/A model: Sony Corporation
type: Li-ion serial: N/A status: not charging
Info: model: Intel Core i7-2620M bits: 64 type: MT MCP arch: Sandy Bridge
gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 809 high: 843 min/max: 800/3400 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 843 2: 798 3: 798 4: 798
bogomips: 21550
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Sony driver: i915 v: kernel arch: Gen-6 code: Sandybridge
process: Intel 32nm built: 2011 ports: active: eDP-1
empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0126
class-ID: 0300
Device-2: Cheng Uei Precision Industry (Foxlink) Webcam type: USB
driver: uvcvideo bus-ID: 2-1.3:5 chip-ID: 05c8:0318 class-ID: 0e02
Display: x11 server: [X.Org](http://X.Org) v: 21.1.7 with: Xwayland v: 22.1.8
compositor: gnome-shell driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: :1
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: Sony LCD serial: built: 2011
res: 1920x1080 hz: 60 dpi: 168 gamma: 1.2 size: 291x164mm (11.46x6.46")
diag: 334mm (13.2") ratio: 16:9 modes: 1920x1080
API: OpenGL Message: Unable to show GL data. Required tool glxinfo
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Sony driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1c20 class-ID: 0403
Sound API: ALSA v: k6.2.1-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.66 running: yes
Device-1: Intel Centrino Advanced-N 6230 [Rainbow Peak] driver: iwlwifi
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0
chip-ID: 8086:0091 class-ID: 0280
IF: wlp2s0 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Sony driver: r8168 v: 8.051.02-NAPI modules: r8169 pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 6000 bus-ID: 05:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp5s0 state: down mac:
IF-ID-1: tun0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
Device-1: Intel Centrino Advanced-N 6230 Bluetooth adapter type: USB
driver: btusb v: 0.8 bus-ID: 2-1.2:4 chip-ID: 8086:0189 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: a060 bus-ID: 00:1f.2 chip-ID: 8086:282a rev: N/A class-ID: 0104
Local Storage: total: 238.49 GiB used: 66.93 GiB (28.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZRPC256HADR-000SO
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: rev: 3S1Q scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: MZRPC256HADR-000SO
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: rev: 3S1Q
ID-1: / raw-size: 110.44 GiB size: 110.44 GiB (100.00%)
used: 66.93 GiB (60.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 110.44 GiB size: 110.44 GiB (100.00%)
used: 66.93 GiB (60.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 110.44 GiB size: 110.44 GiB (100.00%)
used: 66.93 GiB (60.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 110.44 GiB size: 110.44 GiB (100.00%)
used: 66.93 GiB (60.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 5.71 GiB used: 919.2 MiB (15.7%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda2 maj-min: 8:2
System Temperatures: cpu: 61.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 264 Uptime: 19m wakeups: 1 Memory: 5.71 GiB used: 4.5 GiB (78.9%)
Init: systemd v: 253 default: graphical tool: systemctl Compilers:
gcc: 12.2.1 Packages: pm: pacman pkgs: 1568 libs: 493
tools: gnome-software,pamac,paru pm: flatpak pkgs: 0 Shell: fish v: 3.6.0
default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.25
Garuda (2.6.15-1):
System install date: 2022-05-03
Last full system update: 2023-03-02
Is partially upgraded: No
Relevant software: snapper(custom) NetworkManager mkinitcpio
Windows dual boot:
Failed units:

This one looks like a bug with Mutter: The window focus is lost after switching the input method (#2626) · Issues · GNOME / mutter · GitLab

You can either switch to Wayland which does not have the issue, or if you would rather stay on X11 you can downgrade Mutter.

sudo downgrade mutter

Try switching to a 43.2 version if you have one in your cache, or earlier if that doesn't work. You'll have to either re-check (and re-downgrade if it is still broken) after each time you update, or add it to your ignored packages for now in /etc/pacman.conf.

I cannot reproduce this, the function always works as expected when I test it. I have tried both Wayland and X11, and also a variety of applications but it never favors the file exporer and always switches between tasks of whichever application has focus.

Is it possible Nautilus has been opened by Firefox when this happens (as opposed to being opening from the launcher)? I'm just wondering if it might be being counted as a Firefox window for some reason.

1 Like

Switching to Wayland seems to have fixed everything. As an aside, I always thought I was on Wayland. Seems like that should be the default.

I think for many distros, Wayland is the default for a Gnome DE. I'm not sure what the specific reason is that ours defaults to X11, but I believe our Gnome spin is between dedicated maintainers at the moment so that may have something to do with it.

Glad to hear the issues have been resolved. :+1:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.